Discontinued Products

Future development of the PowerCore platform has ceased

As part of a larger strategic review in early 2011, we decided to cease further development of the PowerCore product range, including hardware units as well as software for the PowerCore platform.

With the most recent software release, PowerCore is compatible with the following operating systems:

  • Mac OS X 10.5 Leopard
  • Mac OS X 10.6 Snow Leopard
  • Windows XP
  • Windows Vista
  • Windows 7

The PowerCore drivers support 64-bit operating systems, but note that all plug-ins are 32-bit.

1st Generation PowerCore hardware

2nd Generation PowerCore hardware

PowerCore plug-ins

PowerCore resources